spaar's Mod Loader (1.7.1) [Besiege v0.45a]

This does not work for me man ! I followed the instruction, unistalled, reinstalled step by step by a tutorial for like 5 times cuz i watched 5 different tutorials, yet no result... help me please...
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
This does not work for me man ! I followed the instruction, unistalled, reinstalled step by step by a tutorial for like 5 times cuz i watched 5 different tutorials, yet no result... help me please...
Did you remember to use an older version of Besiege?
 
I don't know how...well i thought it was quite some time since multiverse update and you managed it to work :) but don't worry, i never used mods in besiege so neither i used yours but i can apreciate your work, it's not easy to do what you do :) i hope you will get it to work for latest version
 

ITR

l̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ֍̫̜̥̭͖̱̟̟͉͙̜̰ͅl̺̤͈̘̰̺͉̳͉̖̝̱̻̠̦͈ͅ
Staff member
not working for me (using the UPM mods, they work fine, but the modloader isn't )
using v 0.62-7379, developer mode installed manually
Did you remember to use the old version of the game?
 

spaar

Active Member
Hey would anyone know why windows 10 is blocking the download or anyway to stop it from doing so because it is kinda annoying sense I cant use any mods?
Some antivirus programs / Windows SmartScreen sometimes detect the installer because (by design) it goes ahead and modifies files of another program (the game) which is not normally something you would like programs from the internet to do.

The only way around it for now is to manually tell the AV/SmartScreen that it is actually fine. In the case of SmartScreen, I believe there should be some (small) text or a button somewhere that allows you to download it anyway (possibly hidden behind "More information" or something like that).

Also, keep in mind you need to use an older version of Besiege for the mod loader, it does not work with the current Besiege.
 
the Windows installer didn‘t work for me cuz my PC says that it might damage my PC and even if i still use it it wont work,so i used the manual Linux&Windows download and followed all the steps and installed the version „previousbuild“ which doesnt have multiverse and it always gives me a crash report
 
Hey spaar, can you do the thing already where you stare intently at a screen with this unnecessarily convoluted UI while pounding away at your keyboard for like 10 minutes straight and also occasionally say some cool technobabble and then the modloader is working in the multiverse?
 

spaar

Active Member
@CyanClaw33 Ideally, you install previousbuild Besiege, then download the installer, telling Windows/Your AV/Chrome/whatever that you actually do want to run it, and then it should work.
If it doesn't, you can try the manual installation again, but make sure you *first* switch to previousbuild and then install the mod loader. It wasn't quite clear from your post if you might've done it the other way around.

If that still doesn't work, upload the output_log.txt file from the Besiege_Data/ directory after you tried to start the game and it crashed/didn't work.
 
does the modloader work not for multiverse but just for the levels? id like to use spaars mod loader to use exploding cannonball mod for midlands encampment (level 9)
 
Top